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                particular problem 
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2 2. Flow chart 2.1 About flow chart 
2.2 Various types of box used in flow 

chart and their use(terminal box, 
input/output box, processing box, 
decision box) 
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selection and iteration 
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Minimum level of learning 
Child should be able to develop a solution of a problem and can create its algorithm and 

flow chart 
 

Formative Assessment – 1 

Quarter – July  to September 

3 3. Photoshop Review Topics studied in class VII (Rectangular marquee 
Toole, Lasso, Quick Selection, Crop ,measuring 
,retouching , Painting) 
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                          Freeform Pen 
                          Add Anchor point 
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4.1.13 Applying a mask from a saved 
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4.1.14  Using type as a mask 
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Should be able to identify various tools and where to use the tool 

Should be able to make changes in the picture using tools taught in the classDrawing and type 
toolsIntroduction of tool with its use to be demonstrated to studentsPractical exercise to be 

given to students so that they can learn the specified tool 
Formative Assessment – 2 
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(Continue…) 

5.1 Photoshop 
Vector tools 
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5.3   Output from 
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 Photoshop Vector tools 
5.1.1 Basic Vector paths 
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5.1.3 Combining vector paths 
5.1.4 Converting shapes to selections 
5.1.5 Manipulating vector paths 

 Type in Photoshop 
5.2.1 Typographic design 
5.2.2 Creating a clipping mask from 

type 
5.2.3 Creating a design element from 

type 
5.2.4 Using interactive formatting 

controls 
5.2.5 Wrapping font type 
5.2.6 Designing a paragraph of type 

 Preparing file for print 
 

5.3.1 Preparing file for web output 
File compression 
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6 6. Flash  What is flash and its uses  

 Creating animation 

 About symbols and instances 

 Types of symbols(graphic, 
button,movie clip etc.) 

 Converting an object to a symbol 

 Introducing time line and its use 
in animation 

 Frames and key frame 

 About layers (inserting a new 
layer, renaming & deleting layer) 

 Types of animation (frame and 
tweened) 
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8.1 EDI(Electronic Data Interchange) 
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8.3 Influence on user 
8.4 What factor one should keep in 

mind while doing e-commerce, 
Websites Example 
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9 3. Chatting 9.1 Definition 
9.2 Example 

2 

10 4. Downloading/Uploading 10.1 Downloading/Uploading Speed  
10.2 Difference  
10.3 Example 
10.4 Concept of Bandwidth and 

protocol 
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11 5. Audio and Video 
Conferencing 

 What is it 

 Use of It 

 Factors affecting Video Quality 

 Usefulness of Video Conferencing  
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Minimum level of learning 
Child should be able to create simple flash file having different types of motion 

Child should be able to understand the e-commerce and its various websites and 
what to keep in mind while doing online purchasing 

chatting, downloading and uploading 
Use of video  conferring and its advantage 
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Lesson-1 

Algorithm 
 

Use of algorithm in programming 

 

Developing algorithm to solve particular problem 

In mathematics and computer science, an algorithm is  

a step-by-step procedure for calculations. Algorithms  

are used for calculation, data processing, and automated 

reasoning.Algorithms resemble recipes. Recipes tell you  

how to accomplish a task by performing a number of steps.  

For example, to bake a cake the steps are: preheat the  

oven; mix flour, sugar, and eggs thoroughly; pour into a baking pan; and so forth. 

 

Goals of Algorithm Study 

 To develop framework for instructing computer to perform tasks 

 To introduce notion of algorithm as means of specifying how to solve a problem 

 To introduce and appreciate approaches for defining and solving very complex tasks in 

terms of simpler tasks; 

 

Simple Questions based on Algorithm 

Algorithm: Calling a friend on the telephone 

  

Input: The telephone number of your friend. 

Output: None 

  

 

 Use of algorithm in 
programming 
 

 Developing algorithm 
to solve a particular 
problem 

       You will learn 
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Steps: 

1. Pick up the phone and listen for a dial tone 

2. Press each digit of the phone number on the phone 

3. If busy, hang up phone, wait 5 minutes, jump to step 2 

4. If no one answers, leave a message then hang up 

5. If no answering machine, hang up and wait 2 hours, then jump to step 2 

6. Talk to friend 

7. Hang up phone 

 

Algorithm to create Maggie noddle: 

Step 1: Start 

Step 2: Take pan with water 

Step 3: Put pan on the burner 

Step 4: Switch on the gas/burner 

Step 5: Put magi and masala 

Step 6: Give two minutes to boil 

Step 7: Take off the pan 

Step 8: Take out the magi with the help of fork/spoon 

Step 9: Put the Maggi on the plate and serve it 

Step 10: Stop. 

 

Algorithm: To find (a + b)
2
=(a + b)* (a + b) 

  

Input: Two numbers a and b. 

Output: Result of (a + b)
2
 

  

Steps: 

1. Take numbers a, b, c. 

2. Input the values of a and b 
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3. C=a+b 

4. Print c*c 

 

Algorithm: To find Perimeter of rectangle 

  

Input: Two numbers l and b. 

Output: Result l*b 

  

Steps: 

1. Take numbers l, b, c, d. 

2. Input the values of l and b 

3. c=l*b 

4. d=2*c 

5. Print d 

 

Conditions in Algorithm 

 

Algorithm: To check whether a person can vote or not 

  

Input: A number age. 

Output: Yes or No 

  

Steps: 

1. Take a number age. 

2. Input the age of the person 

3. If(age>=18) goto step 4 
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         Else 

Goto step 5 

4. Print ―You can vote‖ 

5. Print ―You can’t vote‖ 

 

Algorithm: To give a bonus of Rs 1000 to those employees whose salary is more than 

Rs5000 

  

Input: Salary. 

Output: New Salary  

 

Steps: 

1. Take  numbers salary and total. 

2. Input the salary of the person 

3. If(salary>=5000) goto step 4 

         Else 

Goto step 5 

4. total=salary+1000 

5. total=salary+0 

6. Print total 
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1. An algorithm is a step-by-step procedure for calculations. 

2. To develop framework for instructing computer to perform tasksos one of the goal of 

Algorithm. 

 

 

 

A. Short Answer Question 

1. What is an algorithm? 

2. Write few goals of an algorithm.? 

3. Write an algorithm to find Area of square? 

 

 

 

 

 

 

 

 

 

 

 

 

SUMMARY 

EXERCISES 
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Lesson-2 

Flow Char 
 

About flow chart 

A flowchart is a type of diagram that represents an algorithm or  

process, showing the steps as boxes of various kinds, and their  

order by connecting them with arrows. This diagrammatic  

representation illustrates a solution to a given problem. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 About flow chart 
 Various types of box 

used in flow  
chart and their 
use(terminal box,  
input/output box, 
processing box 

, decision box) 
 Question based on  

sequence , selection           

and iteration 

       You will learn 
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Various types of box used in flow chart: 
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Question based on sequence, selection and iteration 

Q 1. Draw a flowchart to find the sum of two numbers 

 

 

 

 

 

 

 

 

 

 

 

 

 

Q 2. Draw a flowchart to find the simple interest.  
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Q 2. Draw a flowchart to find bigger number among two numbers (selective) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Q3. Draw a flow chart to find factorial of any number. (iteration) 
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1. A flowchart is a type of diagram that represents an algorithm or process, showing the  

steps as boxes of various kinds, and their order by connecting them with arrows. 

2. Flowline symbol used to connect the symbols and indicate the flow of logic. 

3. Terminal symbol is used to represent the beginning (Start) or end (End) of task. 

4. Input/Output symbol used to represent reading or writing operations. 

5. Processing symbol used for arithmetic and data manipulation operations. 

6. Decision making symbol used to represent any logic and comparisons operations. 

 

 

1. What is flowchart? 

2. What is the use of flowchart? 

3. Draw the flowchart for 

a) Find the addition of two number. 

b) Find whether a people eligible to give vote or not. 

c) Find given number even or odd. 

d) Find whether a people drive car or not.   

 

 

 

 

SUMMARY 

EXERCISES 
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Lesson-3 

Photoshop Review 

 
 

Review of Photoshop 

An image editing software developed and manufactured  

by Adobe Systems Inc. Photoshop is considered one of  

the leaders in photo editing software. The software allows  

users to manipulate, crop, resize, and correct color 

on digital photos. The software is particularly  

popular amongst professional photographers and 

graphic designers. 

 

 

 

 

 

 

 

 

 

 

 

 About flow chart 
 Various types of box 

used in flow  
chart and their 
use(terminal box,  
input/output box, 
processing box 

, decision box) 
 Question based on  

sequence , selection           

and iteration 

       You will learn 
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Toolbox in detail 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Marquee Tools: The Marquee tool selects a section of the document based on the shape of the 

chosen tool. 

 

 

  

Move Tool: The Move tool moves items in the document, such as selections, layers, and 

guides. 

Lasso Tools: The Lasso tools allow you to select a section of the document either by freehand, 

polygonal, or magnetic selections.  
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• The Lasso tool will close the selection will close 

automatically when the mouse is unclicked. 

 

• The Polygonal Lasso tool and Magnetic Lasso tool need the ends of the selection to be 

joined for the section to become selected. 

 

 

Magic Wand Tool: The Magic Wand tool selects areas of similar colors. 

 

Crop Tool: The Crop tool trims images. 

 

 

Healing Tools: The Healing tools fix up issues in the document such as blemishes and red eye.  

 

• The Spot Healing Brush removes blemishes and objects. 

• The Red Eye tool removes the red reflection caused by a 

flash. 

 

Drawing Tools: The Drawing tools let you draw in your document.  

• The Brush tool paints brush strokes. 

• The Pencil tool paints hard-edged strokes. 

• The Color Replacement tool replaces a selected color with a new color. 

 

Eraser Tools: The Eraser tools erases pixels in the document.  

• The Eraser tool will restore parts of an image to a 

previously saved state or will display the background color. 

• The Background Eraser tool will turn the erased areas into a transparency. 

• The Magic Eraser tool will erase everything of the same color into a transparency. 
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Fill Tools: The Fill tools fill color into areas of the document.  

• The Paint Bucket tool fills in areas of similar color with the 

foreground color. 

• The Gradient Tool creates a smooth straight-line change from the foreground color to 

the background color. 

 

Text Tools: The Type tools add text to a document.  

 

• The type tools create type on top of an image. 

• The type mask tools make a selection of the document in the shape of type. 

 

Shape Tools: The Shape tools draw shapes and lines in a normal layer or a 

shape layer.  

• The Shape tools will create a solid color shape of their type. 

• The Line tool will create a solid color line. 

• The Custom Shape tool makes customized shapes selected from a custom shape list. 

 

 

Color Picking and Measuring Tools: The Color Picking and Measuring tools do 

not actually change the document in any way. 

• The Eyedropper tool changes the foreground color to the color 

that is clicked on. 

• The Color Sampler tool is an advanced tool. 

• The Measure tool measures the distance, location, and angle between to points in the 

document. 
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Hand Tool: The Hand tool moves an image within its window. 

 

 

Zoom Tool: The Zoom tool magnifies and reduces the view of an image. 

 

 

 

 

 

 

1. Photoshop is considered one of the leaders in photo editing software. 

2. The Marquee tool selects a section of the document based on the shape of the chosen tool. 

3. The Move tool moves items in the document, such as selections, layers, and guides. 

4. The Magic Wand tool selects areas of similar colors. 

5. The Color Picking and Measuring tools do not actually change the document in any way. 

6. The Hand tool moves an image within its window. 

7. The Zoom tool magnifies and reduces the view of an image. 

 

 

 

 

 

A. Fill in the blanks 

 

i. ____________moves images within its window. 

ii. Shapes tool draw __________ in a normal layer. 

iii. _________tool fill color into area. 

iv. _________lets you draw in your document. 

B. Find true or false 

i. Marquee tool moves item in the document. 

SUMMARY 

EXERCISES 
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ii. The zoom tool magnifies and reduces the view of an image. 

iii. The color picking and measuring tools moves an image within its window. 

iv. Ms Paint is an example of Photoshop application. 

C. Short Answer Questions 

i. What is Photoshop? 

ii. Write the features of Photoshop.? 

iii. Write the use of 

a) Move tool. 

b) Drawing tool. 

iv. Write one advantage of zoom tool. 

 

In the lab    

 
1. Crop image upto your suitable part of an image and save it. 

2. Insert text some quote on an image using Photoshop tools and save it. 

3. Cut some portion of image and use it in another image using Move tool.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Lesson-4 
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More on Photoshop 
 

 

Drawing and type tools 

The Drawing and Type tools create and alter vector objects.  

Drawing tools work on vector paths, which are vector-based  

outlines you can turn into selections. Using the Options bar,  

choose whether to draw paths or shape layers. Type is  

created in type layers that can be transformed, warped,  

and even set along paths. 

Pen(P) 
 Path Selection (A): Use this tool to move entire paths  

around the canvas as a single object. The path or shape 

layer retains its shape. 

 Direct Selection (A): Use this tool to select and move  

individual points and Bezier handles of a path or shape  

layer. 

 Pen (P): Create paths with the Pen tool (shown in  

Single-click to create individual points to form the path. 

Click, hold, and drag to create a Bezier curve when  

drawing a path. 

 Freeform Pen (P): With this tool, click, hold, and  

draw a path. Points of the path are created automatically. 

 

 

 
Rectangular Marquee 

 Elliptical Marquee 
 Single column Marquee 
 Single Row Marquee 

Lasso 
 Polygonal Lasso 
 Magnetic Lasso 
 Quick Selection 
 Magic Wand 

Crop and Slice tools 
 Crop 
 slice  
 Slice Select 

Measuring tools 
 Eyedropper 
 color Sampler 
 Ruler 
 Note 
 Count 

Retouching tools 
 Spot Healing Brush 
 Healing Brush 
 Patch 
 Red Eye 
 Magic Eraser 
 Blur 
 Sharpen 
 Smudge 
 Dodge 
 Burn 

Sponge 

       You will learn 
 



 

  18 | P a g e  

 

 

 Add Anchor Point (P): Use this tool to click part of a path to add a point to the path. Adding an 

anchor point to your path or shape layer allows for more detail in the path or shape. 

 Delete Anchor Point (P): Use this tool to click a point of a path to remove that point from the 

path. 

 Convert Anchor Point (P): Single-click a point of a path to convert it to a corner point. Or click 

and drag to convert it to a curve point. Or Option-click (Mac users) or Alt-click (Windows users) 

and drag to convert it to a combination point. 

 

Horizontal Type(T):  

The Horizontal Type tool  is the default Type tool. Click and drag to 

make a text box. Type your text with the keyboard to create text in the 

foreground color. Use the Options bar to set the font, size, and other 

text properties. Open the Character and or Paragraph palettes for 

more typography options. 

 Vertical Type (T): This tool is similar to the Horizontal Type tool 

except that the type stacks vertically, and the text direction goes from right to left for Asian 

languages. 

 Horizontal Type Mask (T): This tool is similar to the Horizontal Type tool, but a selection area is 

created rather than actual type. Although you can paint within the type selection area, adjusting 

the type options is not allowed after type is created. 

 Vertical Type Mask (T): This tool is similar to the Vertical Type tool, but a selection area is 

created rather than actual type. Although you can paint within the type selection area, adjusting 

the type options are not allowed after type is created. 
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Rectangle 

There are quite a few predefined vector-based shapes in Adobe Photoshop, all of which can 

be easily added to graphics. There are 6 different kind of Shape Tools in all. 

 

 Rectangle Tool – Creates a rectangle shape (or square if constraining proportions by holding 

shift). 

 Rounded Rectangle Tool – Creates a rectangle with rounded corners. The roundness of the 

corner can be controlled by setting a radius in the options bar. 

 

 Ellipse Tool - Creates an ellipse shape (or perfect circle if constraining proportions by holding 

shift). 

 

 Polygon Tool – Creates a polygon shape with a specified number of 

sides set in the options bar. 

 

 Line Tool – Creates a line shape. 

 

 Custom Shapes – Use predefined shapes (or user created ones) in your graphic. 

To create a shape in your image, simply select the shape tool you want to use, adjust the 

settings for that tool in the options bar, and then drag our your shape in the active image area 

(in the same fashion you’d create a selection with one of the selection tools). 

 

Working with Masks 

Working with masks and channels 
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Photoshop masks isolate and protect parts of an image, 

just as masking tape protects window panes or trim from 

paint when a house is painted. When you create a mask 

based on a selection, the area you have not selected 

is masked, or protected from editing. With masks, you can 

create and save time-consuming selections and then use 

them again. In addition, you can use masks for other 

complex editing tasks—for example, to apply color 

changes or filter effects to an image. 

In Photoshop, you can make temporary masks, called quick masks, or you can create 

permanent masks and store them as special grayscale channels called alpha channels. Photoshop 

also uses channels to store an image’s color information. Unlike layers, channels do not print. You 

use the Channels panel to view and work with alpha channels. 

Creating a quick mask 

Quick Mask mode lets you edit any selection as a mask without using the Channels palette and while 

viewing your image. The advantage of editing your selection as a mask is that you can use almost 

any Photoshop tool or filter to modify the mask. For example, if you create a rectangular selection 

with the marquee tool, you can enter Quick Mask mode and use the paintbrush to extend or contract 

the selection. 

Quick Masks are temporary, so if you create one you really like, be sure to choose Select→Save 

Selection at the end.  

Follow these steps to create your very own Quick Mask: 

 

1. Open a new document and, using any selection tool, select the element you want in your 

image. 

 You can fine-tune your selection after you have the Quick Mask in place. Click the 

Edit in Quick Mask Mode button in the Tools panel (or press the Q key). 



 

  21 | P a g e  

 

 
 If your Quick Mask settings are at the default, a color overlay covers and protects 

the area outside the selection. The selected pixels are unprotected. 

2. Refine the mask by using a painting or editing tool. 

 Paint with black to add to the mask, thereby making the selection smaller. Even 

though you are painting with black, your strokes show up as a red overlay. Paint 

with white to delete from the mask, making the selection larger.  

3. After you finish editing your mask, click the Edit in Standard Mode button in the Tools 

panel to exit the Quick Mask. 

You can also press the Q key. 

The overlay disappears, and a selection outline appears. Your selection is ready and waiting for 

your next command. The selection outline correlates with the unmasked or selected areas of the 

Quick Mask. 

Editing a quick mask 

 

The advantage of editing your selection as a mask is that you can use almost any tool or filter to 

modify the mask. (You can even use selection tools.) 

In Quick Mask mode, you do all of your editing in the image window. Photoshop automatically 

defaults to Grayscale mode. The foreground color defaults to black, and the background color 

defaults to white. When using a painting or editing tool in Quick Mask mode, keep these principles in 

mind: 

 Painting with white erases the mask (the red overlay) and increases the selected area. 

 Painting with black adds to the mask (the red overlay) and decreases the selected area. 

 Painting with gray areas lighter areas are more subject to change than darker areas. 

 

Saving a selection as a mask 
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Quick masks are temporary. They disappear as soon as you deselect. However, you can save a 

selection as an alpha-channel mask so that your time-consuming work won't be lost and you can 

reuse the selection in this work session or a later one. You can even use alpha channels in other 

Photoshop image files. 

Masks are saved in channels, which can be thought of as storage areas for color and selection 

information in an image. 

To avoid confusing channels and layers, think of channels as containing an image's color and 

selection information; think of layers as containing painting and effects. 

You can edit a mask once it has been saved in a channel by painting on it in a channel using black, 

white, and shades of gray. Black areas completely protect an image from changes. White areas are 

completely subject to change. In gray areas, lighter areas are more subject to change than darker 

areas. 

Note If you save and close a file while in Quick Mask mode, the quick mask will show in its own 

channel the next time you open the file. If, however, you save and close your file while in Standard 

mode, the quick mask will be gone the next time you open 

your file. 

Viewing channels 

The first step is accessing channels by choosing Window→Channels. The Channels panel appears 

Selecting a channel in the Channels panel automatically makes it appear in the image window. To 

select a channel, click the channel thumbnail or name in the panel. To select more than one channel, 

Shift-click. To show or hide a channel, click in the eye column in the 

far left of the panel. You can also drag through the column to hide or 

show the channels quickly. 
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Adjusting individual channels 

 

You can select one or more channels in the Channels panel. The names of all selected, 

or active, channels are highlighted 

 

 

Selecting multiple channels 

A. Not visible or editable  

B. Visible but not selected for editing  

C. Selected for viewing and editing  

D. Selected for editing but not viewing 

 

 

 

 

 

 To select a channel, click the channel name. Shift-click to select (or deselect) 

multiple channels. 

 To edit a channel, select it and then use a painting or editing tool to paint in the 

image. You can paint on only one channel at a time. Paint with white to add the 

selected channel’s color at 100% intensity. Paint with a value of gray to add the 

channel’s color at a lower intensity. Paint with black to fully remove the channel’s 

color. 

Loading a mask as a selection 
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The channel mask remains stored in the Channels palette even after you've loaded it as a selection. 

This means that you can reuse the mask whenever you want. To apply a saved mask to an image or 

selection choose Select > Load Selection and then select the mask (alpha channel) you want to use. 

Loading a selection into an image using shortcuts 

You can reuse a previously saved selection by loading it into an image. To load a saved selection 

using shortcuts, do one of the following in the Channels palette: 

 Select the alpha channel, click the Load Channel as Selection button at the bottom of the 

palette, and then click the composite color channel near the top of the palette. 

 Drag the channel that contains the selection you want to load onto the Load Channel as 

Selection button. 

 Ctrl-click (Windows) or Command-click (Mac OS) the channel containing the selection you 

want to load. 

 To add the mask to an existing selection, press Ctrl-Shift (Windows) or Command-Shift (Mac 

OS), and click the channel. 

 To subtract the mask from an existing selection, press Ctrl-Alt (Windows) or Command-Option 

(Mac OS), and click the channel. 

 To load the intersection of the saved selection and an existing selection, press Ctrl-Alt-Shift 

(Windows) or Command-Option- Shift (Mac OS), and select the channel. 

 Applying effects using a gradient mask 

 

How to Create a Transparent Gradient in Photoshop? 

 

1. Create a Photoshop file with two layers - one blank and the other containing the image 

to be made transparent. Select the image's layer. 

2. Click the Add layer mask icon at the bottom of the layer’s palette. 

3. A layer mask is created in the image layer. 
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4. Select the gradient tool and apply a black/white gradient to the 

image layer. 

In the example below, a gradient is applied to the photo from right to left. 

 

  

 

(1) The original image. 

  

(2) With the gradient applied, you can 

see the checkered pattern which 

indicates the blank layer. 
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(3) To fade the photo to white, fill the 

blank layer with solid white. 
  

(4) To fade the photo into another 

image, place the second image in a 

layer below the photo. 

 

 

Resizing the canvass 

The canvas size is the full editable area of an image. The Canvas Size command lets you increase 

or decrease an image’s canvas size. Increasing the canvas size adds space around an existing 

image.  

 

Decreasing an image’s canvas size crops into the image. If you increase the canvas size of an 

image with a transparent background, the added canvas is transparent. If the image doesn’t have a 

transparent background, there are several options for determining the color of the added canvas. 

 

1. Choose Image > Canvas Size. 

2. Do one of the following: 

 

 Enter the dimensions for the canvas in the Width and Height boxes. Choose the units of 

measurement you want from the pop-up menus next to the Width and Height boxes. 
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 Select Relative, and enter the amount you want to add or subtract from the image’s 

current canvas size. Enter a positive number to add to the canvas, and enter a negative 

number to subtract from the canvas. 

3. For Anchor, click a square to indicate where to position the existing image on the 

new canvas. 

4. Choose an option from the Canvas Extension Color menu: 

 Foreground to fill the new canvas with the current 

foreground color 

 Background to fill the new canvas with the current 

background color 

 White, Black, or Gray to fill the new canvas with that color 

 Other to select a new canvas color using the Color Picker 

5. Click OK. 

 

Moving layers between documents 

You can copy any layer, including the Background layer, from one image to another. Keep in mind 

that the resolution of the destination image determines how large the printed copy of the layer can 

be. Also, if the pixel dimensions of the two images are not the same, the copied layer may appear 

smaller or larger than you’d expect. 

1. Open the two images you want to use. 

2. In the Layers panel of the source image, select the layer that you want to copy. 

 

3. Do one of the following: 

 Choose Select > All to select all of the pixels in the layer, and choose Edit > Copy. 

Then make the destination image active, and choose Edit > Paste. 
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 Drag the layer’s name from the Layers panel of the source image into the 

destination image. 

 Use the Move tool (Select section of the toolbox), to drag the layer from the source 

image to the destination image. 

 

Duplicate one or more layers in another image 

You can take any layer, including the Background layer, from one image and duplicate it in another. 

Keep in mind that the pixel dimensions of the destination image determine how large the printed 

copy of the duplicated layer can be. Also, if the pixel dimensions of the two images are not the same, 

the duplicated layer may appear smaller or larger than you’d expect. 

1. Open the source image. If you plan to copy a layer to an existing image rather 

than a new one, open the destination image as well. 

2. In the source document’s Layers panel, select the name of the layer or layers 

you want to duplicate. To select more than one layer, hold down the Ctrl key 

(Command key in Mac OS) and click each player’s name. 

3. Choose Layer > Duplicate Layer, or choose Duplicate Layer from the More 

menu in the Layers panel. 

4. Type a name for the duplicate layer in the Duplicate Layer dialog box, and 

choose a destination document for the layer, and then click OK: 

 To duplicate the layer in an existing image, 

choose a filename from the Document 

pop-up menu. 

 To create a new document for the layer, 

choose New from the Document menu, and 

enter a name for the new file. An image 

created by duplicating a layer has no 

background. 
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Colorizing with an adjustment layers 

The Color Range feature, which is useful for creating a selection area based on sampled colors in an 

image, can also be used to create an adjustment layer mask. 

 

1. In the Layers panel, select the layer to which you want to apply the 

adjustment layer. 

2. Choose Layer > New Adjustment Layer, and choose an 

adjustment type. 

3. In the Masks section of the Properties panel, click Color Range. 

4. In the Color Range dialog box, choose Sampled Colors from the  

5. Select menu. 

6. Select Localized Color Clusters to build a mask based on different 

color ranges in the image. 

7. Set the display option to Selection, and Selection Preview to 

None. 

8. Click a color area in the image. 

As you click on image areas, you can preview the mask in the Color Range dialog box. White 

areas are unmasked pixels, black areas masked, and gray areas partially masked. 

9. Use the Fuzziness slider to increase or decrease the range of colors around your sample 

colors that are included in the masked area. Use the Range slider to control how far or near a 

color must be from the sample points to be included in the mask. After adjusting the mask, 

click OK to close the Color Range dialog box. 

10. Modify the adjustment as needed in the Properties panel. 
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Grouping and clipping layers 

Grouping layers helps organize your projects and keeps your Layers panel uncluttered. By linking 

layers, you establish a relationship between them, even if they aren't next to each other in your layer 

order. 

Group and ungroup layers 

1. Select multiple layers in the Layers panel. 

2. Do one of the following: 

 Choose Layer > Group Layers. 

 

 Alt-drag (Windows) or Option-drag (Mac OS) layers to the folder icon  at the bottom 

of the Layers panel to group the layers. 

3. To Ungroup the layers, select the group and choose Layer > Ungroup Layers. 

Add layers to a group 

 Do one of the following: 

 Select the group in the Layers panel and click the Create a New Layer button . 

 Drag a layer to the group folder. 

 Drag a group folder into another group folder. The group and all of its layers move. 

 Drag an existing group to the New Group button . 

CLIPPING MASKS 

A clipping mask is a group of layers to which a mask is applied. 

The bottommost layer, or base layer, defines the visible 

boundaries of the entire group. For example, suppose you have a  
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shape in the base layer, a photograph in the layer above it, and text in the topmost 

layer. If the photograph and text appear only through the shape outline in the base 

layer, they also take on the opacity of the base layer. 

You can group only successive layers. The name of the base layer in the group is underlined, and 

the thumbnails for the overlying layers are indented. Additionally, the overlying layers display the 

clipping mask icon. 

 

The shape in the bottom layer of the clipping mask determines what area of the photo layer above 

shows through. 

 

Create a clipping mask 

 

1. Do one of the following: 

 Hold down Alt (Option in Mac OS), position the pointer over the line dividing two layers 

in the Layers panel (the pointer changes to two overlapping circles), and then click. 

 In the Layers panel, select the top layer of a pair of layers you want to group, and 

choose Layer > Create Clipping Mask. 

2. When making a clipping mask from an existing layer and one you are about to create, first 

select the existing layer in the Layers panel.  

Then choose New Layer from the Layer menu or the Layers panel More menu. In the New 

Layer dialog box, select Use Previous Layer to Create Clipping Mask, and click OK. 

Applying a mask from a saved selection 

 

To be demonstrated in practical class by teacher. 
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Using type as a mask 

Using the Type Mask tool in Photoshop Elements epitomizes the combination of type and image. The 

Type Mask tool doesn’t create a new layer. Instead, it creates a selection on the active layer. This is 

the tool of choice for filling text with an image or cutting text out of an image so that the background 

shows through. 

Here are the steps to create a type mask: 

1. In Edit Full mode, open the image of your choice. 

2. Convert your background into a layer by double-clicking the word 

Background on the Layers panel; and then click OK. 

3. Choose the Horizontal Type Mask tool from the Tools panel. 

4. Specify your type options (such as font family, style, and size) on 

the Options bar. 

Horizontal Type Mask tool settings on the Options bar. 

5. Click the image and type your desired text. When you’re done, click the Commit button on the 

Options bar. 

A selection border in the shape of your type appears on your image. 

6. Choose Select→Inverse, which deselects your letter selections and selects everything else. 

7. Press the Backspace (Delete on a Mac) key to delete everything outside your selection border. 

Your type is now filled with your image. 

8. Choose Select→Deselect. 

9. Experiment with applying layer styles to your type. 
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1. The Drawing and Type tools create and alter vector objects. Drawing tools work on vector 

paths, which are vector-based outlines you can turn into selections. 

2. The Horizontal Type tool  is the default Type tool. Click and drag to make a text box. 

3. Rectangle tool  createsa rectangle shape (or square if constraining proportions by holding 

shift). 

4. Photoshop masks isolate and protect parts of an image, just as masking tape protects window 

panes or trim from paint when a house is painted. 

5. Quick Mask mode lets you edit any selection as a mask without using the Channels palette 

and while viewing your image. 

6. Grouping layers helps organize your projects and keeps your Layers panel uncluttered. 

7. A clipping mask is a group of layers to which a mask is applied. The bottommost layer, or base 

layer, defines the visible boundaries of the entire group. 

8. Using the Type Mask tool in Photoshop Elements epitomizes the combination of type and 

image. 

9. Path Selection tool use to move entire paths around the canvas as a single object. The path or 

shape layer retains its shape. 

10. Direct Selection tool use to select and move individual points and Bezier handles of a path or 

shape layer. 

11. Vertical type tool is similar to the Horizontal Type tool except that the type stacks vertically, 

and the text direction goes from right to left for Asian languages. 

12. Horizontal TypeMask  is similar to the Horizontal Type tool, but a selection area is created 

rather than actual type. 

13. Custom Shapes Use predefined shapes (or user created ones) in your graphic. 

 

SUMMARY 
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A. Fill in the blanks 

i. ___________ use this tool to move entire path around the canvas as a single 

Object. 

ii. __________ is the default type tool. 

iii. __________ is predefined vector based shapes in adobe photoshop. 

iv. __________create line Photoshop. 

v. __________ mode lets you edit any selection as a mask without using the channels  

Palette while viewing your channel. 

vi. You can edit a ______________ once it has been saved in a channel by pointing on 

It in a channel using black, white and shades of gray. 

vii. The first step in accessing the channels by choosing window____________. 

 

B. Find true or false 

i. The canvas size is the full editable area of an image. 

ii. We cannot copy any layer. 

iii. The color range feature can also be used to create an adjustment layer mask. 

iv. Grouping layer helps organize your projects and keeps your layer panel  

uncluttered. 

v. The drawing and type tools does not create and alter vector objects. 

vi. Photoshop masks edit any selection as a mask without using the channels palette  

and while viewing your image. 

vii. Path selection tool use to move entire image from one location to other. 

viii. Direct selection tool use to select and move individual points and Bezier handles  

Of a path. 

 

C. Short Question Answers 

i. What is clipping mask? 

EXERCISES 
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ii. Write the steps to Group and Ungrou0p layers.? 

iii. Write the steps to access channels.? 

iv.  What do you mean by Quick Mask? 

v. Write one difference between Horizontal type Mask with Vertical type Mask? 

 

 

 

In the lab    

 

 

1. Apply gradient mask to a image with two different images. 

2. Create one Clipping mask on a image. 
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Lesson-5 

Photoshop Continued 

 
Photoshop Vector tools 

 
Vector shapes are lines and curves you draw using the  

shape or pen tools. Vector shapes are resolution- 

independent—they maintain crisp edges when resized,  

printed to a PostScript printer, saved in a PDF file, or  

imported into a vector-based graphics application. You  

can create libraries of custom shapes and edit a shape’s  

outline (called a path) and attributes (such as stroke, fill  

color, and style).Paths are outlines that you can turn into  

selections, or fill and stroke with color. You can easily  

change the shape of a path by editing its anchor points. 

A work path is a temporary path that appears in the Paths  

panel and defines the outline of a shape. 

You can use paths in several ways: 

Use a path as a vector mask to hide areas of a layer 

 

 Convert a path to a selection.  

 Fill or stroke a path with color.  

 

Designate a saved path as a clipping path to make 

part of an image transparent when exporting the 

image to a page-layout or vector-editing application 

 

 

 Photoshop Vector tools 
 Basic Vector paths 
 Drawing shapes 
 Combining vector paths 
 Converting shapes to selections 
 Manipulating vector paths 

 Type in Photoshop 
 Typographic design 
 Creating a clipping mask from 

type 
 Creating a design element from 

type 
 Using interactive formatting 

controls 
 Wrapping font type 
 Designing a paragraph of type 

 Preparing file for print 
 Preparing file for web output 
 File compression 

 

You will learn 
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Basic Vector paths 

 A path consists of one or more straight or curved segments. Anchor points mark the end points of 

the path segments. On curved segments, each selected anchor point displays one or two direction lines, 

ending in direction points. The positions of direction lines and points determine the size and shape of a 

curved segment. Moving these elements reshapes the curves in a path. 

 

A. Curved line segment  

B. Direction point  

C. Direction line  

D. Selected anchor point  

E. Unselected anchor point  

A path 

 

A path can be closed, with no beginning or end (for example, a circle), or open, with distinct end  

points (for example, a wavy line). 

Smooth curves are connected by anchor points called smooth points. Sharply curved paths are  

connected by corner points.        

 

 

 

 

 

 

 

Smooth point and corner point 

 

When you move a direction line on a smooth point, the curved segments on both sides of the point are 

adjusted simultaneously. By comparison, when you move a direction line on a corner point, only the curve 

on the same side of the point as the direction line is adjusted. 
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Adjusting a smooth point and a corner point 

 

A path does not have to be one connected series of segments. It can contain more than one distinct and 

separate path component. Each shape in a shape layer is a path component, as described by the layer’s 

clipping path. 

Drawing shapes 

 

Straight line paths 

 

 

Drawing a straight line is easy, you could use the line tool or the pen tool. 

1. Choose the Pen tool on the toolbox. 

2. Select the drawing option from the options bar to draw either a path, Shape layer or fill pixels. 

3. Click once to mark the starting point, then Ctrl-click somewhere else (without dragging) to mark 

the ending point. A straight line connects the dots. 

4. You can also keep clicking to keep adding straight line segments—to create,  

5. Choosing the pen tool will enable you to draw paths easily. Choosing a different kind of pen 

tool will give you a different behavior. 

 

http://photoshopcafe.com/wp-content/uploads/2014/06/paths1.jpg
http://photoshopcafe.com/wp-content/uploads/2014/06/penoptions.jpg
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U-shaped curves 

To create a U-shaped curve: 

1. Drag downward. As you drag you will notice that two handles 

are being created.  

2. Move your pointer to the right, parallel with the first point that you made; click and drag 

upward. 

Click and drag up and you will now see a U shaped curve being generated. The curve goes 

in the direction that you are dragging. 

Simple S curves 

Creating a simple S-curve. Notice that as you change the angle of your 

drag, the shape of the curve also changes. 

An S-curve is only slightly more complex: 

1.  Drag to the left. 

The direction handles are being created. 

2.   Position your pointer underneath the first point. Drag to the left again. 

 M curves 

The M curve is a little trickier because it involves a new tool: The Convert 

Point tool. The convert point tool is found under the pen tool in the tool box 

1. From your starting point, drag upwards. You are creating the 

direction handle. 

2. Move to the right and parallel, drag downward. You are creating an 

inverted U curve right now. 

3.  Now the tricky part: Hold the Alt (Option) Key and drag upward. First you define a direction with 

http://photoshopcafe.com/wp-content/uploads/2014/06/paths2.jpg
http://photoshopcafe.com/wp-content/uploads/2014/06/paths3.jpg
http://photoshopcafe.com/wp-content/uploads/2014/06/paths5.jpg
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a direction handle (The initial drag of the mouse). The next click actually draws the curve based 

on the direction of the first drag and the second. If you want a sharp curve (called a cusp), you 

need to first change the direction of the handle without affecting the previously drawn curve. The 

Convert point tool, is such the tool for this task. The Alt (Option) Key is a quick way to temporarily 

choose the Convert Point tool. 

1. Position your pointer to the right of the second point and drag down 

You’ve just made an M curve. 

Closed paths 

A closed path. X marks the start/end point.  To help in creating your 

curves, you may want to show the grid under the View>Show menu. 

The paths described so far are open paths—that is, they’re not fully 

enclosed shapes. They’re just lines, and therefore you can’t use them to 

select areas of your image, or fill them up with solid colors  

A closed path, on the other hand, can be filled with color, texture or 

patterns. It can be turned into a selection to use on an image. 

1. Repeat the steps for the M curve. 

2. Click to add a point beneath the other three points.In the middle, the shape of the heart begins 

forming. 

3. Finally, point to the first point you created, without clicking. 

 A small circle appears by the pointer. It tells you that your mouse is hovering over the 

initial starting point. Click on the circle to close the path and form a closed loop. 

4. Click the point to close the path and complete your heart. 

Combining vector paths 

http://photoshopcafe.com/wp-content/uploads/2014/06/paths6.jpg
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If you’re using the Pen tool (P), and you’ve created multiple paths within your document, these paths 

are totally separate, and are moved independently of one another. However, if you want these paths 

to move as one unit—combine them. Just switch to the Path Selection tool (Shift-A until it comes up), 

then go up to the Options Bar and click on the Combine button. Now when you move one path, all the 

combined paths move right along with it. 

Converting shapes to selections 

Convert paths to selection borders 

Paths provide smooth outlines that you can convert into precise selection borders. You can also 

convert selection borders into paths, using the Direct Selection tool  for fine-tuning. 

You can define any closed path as a selection border. A closed path can be added to, 

subtracted from, or combined with the current selection. 

 

Convert a path to a selection border using the current settings 

1. Select the path in the Paths panel. 

2. To convert the path, do one of the following: 

 Click the Load Path as a Selection button  at the bottom of the Paths panel. 

 Ctrl-click (Windows) or Command-click (Mac OS) the path thumbnail in the Paths 

panel. 

Convert a path to a selection border and specify settings 

1. Select the path in the Paths panel. 

2. Do one of the following: 

 Alt-click (Windows) or Option-click (Mac OS) the Load Path As A Selection button 

 at the bottom of the Paths panel. 
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 Alt-drag (Windows) or Option-drag (Mac OS) the path to the Load Path As A 

Selection button. 

 Choose Make Selection from the Paths panel menu. 

3. In the Make Selection dialog box, select a Rendering option: 

Feather Radius 

Defines how far inside and outside the selection border the feather edge extends. Enter a 

value in pixels. 

Anti-aliased 

Creates a finer transition between the pixels in the selection and the surrounding pixels. 

Make sure the Feather Radius is set to 0. 

4. Select an Operation option: 

New Selection 

Selects only the area defined by the path. 

Add To Selection 

Adds the area defined by the path to the original selection. 

Subtract From Selection 

Removes the area defined by the path from the current selection. 

Intersect With Selection 

Selects the area common to both the path and the original selection. If the path and selection 

do not overlap, nothing is selected. 

5. Click OK. 

 

Manipulating vector paths 
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You can reorder saved paths that are not Shape, Type, or Vector Mask paths in the Paths panel. 

 In the Paths panel, drag the path to the position you want. In Photoshop CC, you can select 

and drag more than one path simultaneously. 

Duplicate paths 

1. In the Paths panel, select the path you want to duplicate. In Photoshop CC, you can select 

more than one path. 

2. Do any of the following: 

 Alt-drag (Windows) or Option-drag the paths. 

 Choose Duplicate Path from the panel menu. 

Adjust path segments 

You can edit a path segment at any time, but editing existing segments is slightly 

different from drawing them. Keep the following tips in mind when editing segments: 

 If an anchor point connects two segments, moving that anchor point always changes both 

segments. 

 When drawing with the Pen tool, you can temporarily activate the Direct Selection tool so 

that you can adjust segments you have already drawn; press Ctrl (Windows) or Command 

(Mac OS) while drawing. 

 When you initially draw a smooth point with the Pen tool, dragging the direction point 

changes the length of the direction line on both sides of the point. However, when you edit 

an existing smooth point with the Direct Selection tool, you change the length of the 

direction line only on the side you are dragging. 

 

Move straight segments 

1. With the Direct Selection tool , select the segment you want to adjust. 

2. Drag the segment to its new position. 
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Adjust the length or angle of straight segments 

1. With the Direct Selection tool, select an anchor point on the 

segment you want to adjust. 

2. Drag the anchor point to the desired position. Shift-drag to constrain the 

adjustment to multiples of 45°. 

Adjust the position or shape of curved segments 

1. With the Direct Selection tool, select a curved segment, or an anchor point 

on either end of the curved segment. Direction lines appear, if any are present. 

(Some curved segments use just one direction line.) 

2. Do any of the following: 

 To adjust the position of the segment, drag the 

segment. Shift-drag to constrain the adjustment to 

multiples of 45°. 

 

Click to select the curve segment. Then drag to adjust. 

 

 To adjust the shape of the segment on either side 

of a selected anchor point, drag the anchor point 

or the direction point. Shift-drag to constrain 

movement to multiples of 45°. 

 

Drag the anchor point, or drag the direction point. 

 

Type in Photoshop 
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 Type in Photoshop consists of mathematically defined shapes that describe the letters, 

numbers, and symbols of a typeface. When you add type to an image in Photoshop, the characters 

are composed of pixels and have the same resolution as the image file. However, Photoshop 

preserves the vector-based type outlines and uses them when you scale or resize type, save a PDF 

or EPS file, or print the image to a PostScript printer. 

Typographic design 

1. Choosing your image and preparing the canvas 

  Start by choosing a portrait image you’d like to turn into a Typography Poster. It’s best 

to choose a large image so you can see all the features of the face clearly. 

 

2. Adding in Color Range Shadows and Mid Tones 

To select the appropraite areas on the face you’ll be using the Color Range Tool. This will select all 

the different tones on the face. Each time a Color Range is selected you’ll copy and paste it onto a 

new  layer. You’ll be removing the original image from view to have a transparent background. 

 

 

 

 

 

 

 

http://designbump.com/wp-content/uploads/2014/01/typography-portrait-photoshop-tutorial-001.jpg
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3. Converting to Black and White and Merging the 2 Color Range Layers 

 

 

You’ll then to converting the 2 Tones into Black and White and merging the two layers together. 

4. Create a new Canvas and add Text 

Next you create a new canvas with the same size 

as the portrait image. Write out the text you’d like in 

the Typography Portrait; a poem or quote might add 

a nice touch rather than meaningless words. 

 

 

 

5. Adding in yout Text 

The text is then turned into a Brush and clicked onto the portrait canvas into a new layer using varient 

brushes sizes. A mask layer it then placed on the text layer. Go to your portrait layer and copy the 

image, the mask layer is click where you paste in the image. The portrait image on the mask layer is 

http://designbump.com/wp-content/uploads/2014/01/typography-portrait-photoshop-tutorial-004.jpg
http://designbump.com/wp-content/uploads/2014/01/typography-portrait-photoshop-tutorial-003.jpg
http://designbump.com/wp-content/uploads/2014/01/typography-portrait-photoshop-tutorial-002.jpg
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then inverted. You then click back onto the original text layer and remove the original portrait layer 

from view to see the new typographic portrait. 

 

 

 

 

 

6. Gradient and Final Touches 

A Gradient Option is added using Blending Options and a soft brush is selected and brushed on 

certain areas of the face using the color black and an opacity of 33% to enhance certain areas. 

 

 

 

 

 

 

 

 

 

 

http://designbump.com/wp-content/uploads/2014/01/typography-portrait-photoshop-tutorial-006.jpg
http://designbump.com/wp-content/uploads/2014/01/typography-portrait-photoshop-tutorial-005.jpg
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Creating a clipping mask from type 

A clipping mask is an object or a group of objects whose shape masks other artwork so that only 

areas that lie within the shape of the masking object are visible. In effect, you are clipping the artwork 

to conform to the shape of the object (or mask). In Photoshop, you can create a clipping mask from 

shapes or letters. 

Creating a design element from type 

  To be demonstrated in practical class by teacher 

 

Using interactive formatting controls 

The Character palette in Photoshop contains many options to help 

you set beautiful type, but not all of the choices and controls are 

obvious—as in the trick of scrubbing the Tracking icon to 

choose a tracking value. 

 

 

 

Select text in the image window, and in the Character palette or on the Type tool options bar you can 

do the following: 

 Scrub the Size, Leading, Tracking, Kerning, Scaling, and Baseline Shift values. 
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 Select some type in the image window, click the font displayed in the Font Family pop-up 

menu, and press the up and down arrow keys to cycle through the available fonts and watch 

them preview interactively in the image window. 

Wrapping font type 

Warping lets you distort type to conform to a variety of shapes, such as an arc or a wave. You can 

change a layer's warp style at any time to change the overall shape of the warp. Warping options 

give you precise control over the orientation and perspective of the warp effect. 

 

 

Designing a paragraph of type 

               

In Photoshop, you will often use point type - a few discrete words or lines – which are added by 

clicking once with the Type tool and then adding some text. Often, however, a design may call for full 

paragraphs of text. You can design complete paragraphs of type in Photoshop and you don't have to 

switch to page-layout program to get paragraph type 

control. In this short tutorial I'll show you how to do it. 

 

Step 1 

Open or create an image that you want to add a 

paragraph of text to. I'm using this picture of a couple of 

pears. 
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Step 2 

Select the Horizontal Type tool (), and in the Character palette, choose a typeface. I'm using Century, 

I've set the Size to 12 points, Leading to Auto, Tracking to 0, and text Colour to white. 

  

  

 

 

 

 

Step 3 

Click the Paragraph tab to bring the Paragraph palette forward, and click the Justify Last Left button. 

  

  

 

 

 

 

 

Step 4 

Select the Horizontal Type Tool from the toolbox and instead of just clicking once on the document 

window, click and drag out a rectangular marquee. 
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This creates a text box into which your text will flow. 

 

 

 

 

 

 

You will notice a small flashing cursor inside the text box. Start typing in your text, or if you have 

copied some text from another document or web page, press Ctrl+V (windows) to paste the text that 

you copied into the text box. Your text will now flow neatly from one side of the text box to the other, 

because you selected Justified from the paragraph 

palette. 
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Step 5 

 

Once your text is in the text box, you can use the Move tool to drag the text to wherever you want on 

the image. 

Preparing file for print 

 Always transform your images in their native application. Size, crop, rotate, shear, and reflect 

art in Photoshop.  

 Ensure that images can first print from Photoshop. Do this before importing the images into an 

illustration or page layout program. 

 When saving Photoshop images for print purposes, stick to TIFF, EPS, native PSD, or PDF 

file formats. 

 Make sure that you use the proper color mode. For example, use CMYK for color separations 

for offset printing and RGB for photographic prints. 

 Create vector shapes and paths efficiently. Use the fewest number of anchor points possible 

to create the path and delete any unnecessary or stray points. 

 Make sure that all scanning is at the appropriate resolution. 

 If your image is to bleed (extend to the edge of the printed page), take that into account when 

creating your image. Note that you need to allow for 1/8 to 1/4 of an inch on any side that will 

bleed to allow for slippages when the paper is cut. 

 When using spot colors, always specify colors from a Pantone color swatch chart and then 

select the color, whether process or spot, in Photoshop. 

 Print and provide laser or inkjet prints of your file, both separations (if warranted), and a 

composite print.  

 Provide all fonts used in your file. Provide both screen and PostScript printer fonts, if 

applicable. 

 Choose File→Save As for your final save to squeeze down to the smallest file size. 

 Organize your files into folders. 
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Preparing file for web output 

What Makes a Graphic “Web-Ready” image in Photoshop 

1. Resolution is 72 dpi 

2. Color mode is RGB 

3. Generally reduced in file size for faster 

4. Format is mainly jpeg, bmp or gif 

 

This process utilizes five steps: 

1. Downsize the image. 

2. Sharpen the image. 

3. Save a copy of the image with the layers. 

 

4. Convert the color space/flatten the image. 

5. Convert to eight-bit image. 

6. Save the JPEG image. 

File compression 

1. Open an image to experiment with.If you copy an image from the clipboard, choose File --> 

New from Clipboard. 

2. Choose File --> Save As (Ctrl+Shift+S) to save the original image. 

3. Choose File --> Save For Web (Alt+Shift+Ctrl+S) or choose the Save For Web icon in the 

Shortcuts bar. 

4. Inspect the settings contained in the Save For Web dialog box. 

5. The JPEG quality setting is set to Maximum/100 by default 

6. Adjust the quality settings — High (60%), Medium (30%), and Low (10%) — in the Settings 

drop-down list and then fine-tune the numeric settings in the Quality text box. 
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7. Type a number, such as 40 or 50 percent, to make additional changes to the numeric 

setting. 

8. Photoshop and Photoshop Elements use lower compression values to indicate more 

compression and a smaller file size (100 = least compression, 1 = most);  

9. Click OK when you're ready to save your image. 

 

 

1. Vector shapes are lines and curves you draw using the shape or pen tools. 

2. Vector shapes are resolution-independent—they maintain crisp edges when resized, printed to 

a PostScript printer, saved in a PDF file, or mported into a vector-based graphics application. 

3. A path consists of one or more straight or curved segments. Anchor points mark the end points 

of the path segments. 

4. Type in Photoshop consists of mathematically defined shapes that describe the letters, 

numbers, and symbols of a typeface. 

 

5. A clipping mask is an object or a group of objects whose shape masks other artwork so that 

only areas that lie within the shape of the masking object are visible. 

6. Warping lets you distort type to conform to a variety of shapes, such as an arc or a wave. You 

can change a layer's warp style at any time to change the overall shape of the warp. 

 

A. Fill in the blanks 

 

i. ___________ consist of one or more straight or curved segment. 

ii. A path can be ____________, with no beginning or and or open with distinct end 

points. 

 

SUMMARY 

EXERCISES 
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iii. A closed path X marks the _________point. 

iv. When saving Photoshop images for print purpose stick to TIFF, EPS, 

native ______________, _______________. 

v. To save Photoshop original image type Ctrlc +_________+_________. 

vi. The JPEG quality setting is set to maximum __________by default. 

vii. Quality setting of Photoshop ________%, ________%,__________% in the  

setting drop down list. 

 

B. Find true or false 

 

i. Choose File Save for web(Shiftc + Alt + S). 

ii. Typographic design means image reflect text. 

iii. M curves is a little tricker because it involves a new tool : the covert point tool. 

iv. To draw U curve you change the angle of your drag, the shapes of the curve  

Also changes. 

v. A path cannot be closed. 

vi. Vector shapes are lines and curves you draw using shapes or pen tools. 

 

 

C.  Short Answer Question 

 

i. What is vector tool? 

ii. Write about path of Photoshop.? 

iii. How to draw U and S shapes.? 

iv. What is typographic design? 

v. What do you mean by wrapping font in Photoshop? 

vi. Write few points to prepare file for print? 

vii. Write the steps for preparing file for web output.? 

viii. What is file compression? 
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In the lab    

 

1. Create typography design on an image and save it. 

2.  Sunil wants to add Quotes on an image but he is getting trouble in it. Can you help  

Sunil to achieve his solution? 

3. Draw closed path line using vector tool. 
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Lesson-6 

                                Flash 

What is flash and its uses 

Flash 8 is a powerful tool created by Macromedia that has  

overcome the best expectations of its creators. Macromedia 

Flash was originally created in an effort to realize colorful  

animations for the web as well as to create animated GIFs. 

Designers, web professionals and amateurs 

have selected Flash 8 by many reasons. 

 
 
 
 
 
 

 

 

Why should I use FLASH 8? 
  

The possibilities of Flash are extraordinary, each new version has outstripped the previous one, 

and the present Flash 8 is not an exception. Although its common usage is to create animations 

has far more applications. They are so numerous that all web designers should learn how to use 

Flash. 

Flash has been made up in order to fix the great lack in the Internet: that is, Dynamism. This 

dynamism does not imply only animations but rather interactive animations, which allow users to 

see the web as something attractive, not static (unlike most of the pages that are made by the use 

of the HTML language). With Flash we can easily and quickly create animations of all types. 

It is easy to learn how to handle Flash, it has a friendly environment that invites us to sit down and 

spend hours making whatever our imagination suggests, but that is not sufficient to be preferred 

by professional designers 

 What is flash and its uses  
 Creating animation 
 About symbols and 

instances 
 Types of symbols(graphic, 

button,movie clip etc.) 
 Converting an object to a 

symbol 
 Introducing time line and its 

use in animation 
 Frames and key frame 
 About layers (inserting a 

new layer, renaming & 
deleting layer) 

 Types of animation (frame 
and tweened) 

 

       You will learn 
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Features of flash 

 Attractive Designs: Flash 8 allows the using of visual effects that will ease the creation of 

animations, presentations and forms more attractive and professional 

 Font Optimization: It also includes some readability options for small sized fonts, what makes 

our texts more comfortable to read. 

 Consolidated Libraries: Now you can search any object existent in our movies faster, browsing 

our open libraries from a single panel. 

 More powerful animation: Flash 8 allows much more control of the interpolations setting a new 

edition mode form which you will edit the velocity the rotation, shape, color and movement are 

applied. 

 More powerful graphics: Avoid the unnecessary representation of vectorial objects setting an 

object as a bitmap. 

 Improvements in video importing: To ease the working with video formats, Flash 8 provides 

high-quality new independent codec, completely skinnable. 

 Metadata Compatibility: Include your SWF files in searching engines defining a title, description 

and/or keywords. 

 Mobile devices Emulator: Preview your Flash Lite compatible mobile devices movies oriented 

with the new emulator Flash 8 includes. 

Creating animation 

One of the main characteristics of Flash 8 is its simplicity, the 

straightforwardness in its use allows to create animations in 

an effective and quick way. 

Let's suppose you want to create an animation in which a 

globe goes up and down. It may seem a job for long hours, 

but it is not as bad. Let's see how easy is to handle it with 

Flash. 

At first glance, it seems logical to draw the globe at each moment, so that growing number of 

moments makes the movement more real: the more drawn instants, the more realistic movement. 
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Nevertheless, with Flash it is sufficient to create only 3 frames: firstly, we will draw the globe at the 

initial instance (above all), secondly, we will draw the globe at the moment when it touches the 

ground and then the globe will come back to its initial position (actually you can create this frame 

by making a copy of the first one).So far as we see now, most part of the work (drawing objects) is 

already done. 

  Now, the duration of each movement is determined 

by setting the time between the moments when the globe 

is at the top and at the bottom, and finally Flash is pointed 

out to create an animation of movement between those 

two frames. It is easy, isn't it? 

 

About symbols and instances 

The Symbols come from objects that we've created using the tools that Flash 8 provides us. When 

transforming these objects into symbols, they are included in a library at the moment of creation that 

allows us using them on several occasions, either in the same or another movie 

When we create a symbol, Flash saves it to a library. Every time we use this object in a movie, it's 

converted into an instance. 

Although they seem to be the same, there is an important distinction: when using a symbol, after 

we've created it for our movie, on modifying it the instance will be updated, whereas the object will 

continue being intact, as it was at the moment of its creation, so then we'll be able to return to use it 

at another moment. 

 

Types of symbols (graphic, button, movie clip etc.) 

Graphic symbols 
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Graphic symbols are the simplest and most obvious type of symbol. When you create a Flash movie, 

you create objects on the Stage. Some objects may remain still, such as backgrounds 

You create graphic symbols to reduce the size of your file and to make it easier to add multiple copies 

of a graphic to your movie. Symbols are stored in the Library and are available to not only the movie 

in which you created them but also any other movie. Therefore, using symbols is a good way to store 

graphic images for use in Flash movies.  

Movie Clip Symbols 

A movie clip is like a movie within a movie that you can manipulate by using interactive controls (also 

called actions, created with ActionScript). A movie clip doesn't take place on the main Timeline; 

instead, it has its own Timeline. For example, you can go to a movie clip at any time, play it, and then 

return to where you left off on the Timeline. You can also attach movie clips to buttons. 

Flash comes with several components, special movie clips that allow you to add user interface 

elements — such as radio buttons, check boxes, and scroll bars — to your movies.  

Button Symbols 

Button symbols create buttons — those little graphics that you click in Web sites to take you to other 

places on the site or the Internet. In Flash, you can use buttons in the same way, but you can also 

use buttons to let viewers decide whether they want to see a movie — when they click the button, the 

movie starts. 

Converting an object to a symbol 

 We select the object that we want to convert to a symbol. We open the dialog box of Symbol 

Properties, acceding to the menu Insert → New Symbol or just by pressing Ctrl + F8 or F8. 
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 Type a name of the symbol, which we are going to create. 

 The only that remains is to select the type of symbol or behavior into which we convert our 

object. We can choose between Movie Clip, Button and Graphic.. 

 Click OK to create our symbol. 

 

Introducing time line and its use in animation 

The Timeline represents a simple mode of visualization. It consists of two parts: 

1) The Frames that are limited by vertical lines (forming rectangles) 

2) The Numbers of frames that allow us to know the assigned number of each frame, its 

duration and when it will appear in the movie. 

  Moreover, there are some tools on the bottom to work with Onion paper and its information 

about the Number of current frame (1 in the image), the frame Speed (12.0 in the image) and 

the Time of the movie (0.0 in the image). 

On the definition level, ―the Timeline represents the succession of frames in the Time‖. The 

Flash movie will not be only the frames that appear on the Timeline one after another in the order 

established by the same Timeline 
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Frames and key frame 

  A frame represents the content of the movie at one moment of time. So far, an animation is nothing 

more as a succession of frames. You can control all these from the Timeline, but not all the frames 

have the same behavior and can be treated equally.  

Key Frame They are frames with specific contents that are created to insert into the movie inexistent 

content. You can identify them by the black point that is in the centre or by the black vertical line. 

 

 

 

About layers (inserting a new layer, renaming & deleting layer) 

A Layer could be defined as one independent movie of only one level. That is to say, 

one layer contains its own Timeline (with endless frames) 

The objects that are at one Layer share a frame and due to this fact they can "get mixed up" among 

themselves. Frequently it could be interesting, but other times it is convenient to separate the objects 

in order that they do not interfere among them. For this, we will create as many layers as necessary. 
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Insert Layers  : As its name indicates, it is used for Inserting layers in the present scene. It inserts 

normal layers (in the following point the different types from layers will be 

seen). 

 

 

 

 

Erase Layer  : Erase the selected layer. 

Change Name: To change Name: of a layer, it is enough to double click the current name. 

Layer Properties: If we double click the icon , we'll be able to access a panel with 

the properties of the layer we've clicked. We'll be able to modify all the options that we've previously 

commented and some more of lesser importance. 

 

 

 

 

 

Show /Hide Layers  : This button allows us to show and hide all layers of the movie. It is very 

helpful when we have many layers and we want only to see one of them. In order to activate the view 

of a concrete layer (or to hide it) it is enough to click the corresponding layer in the point (or in the 

cross) that is under the icon "Show/Hide layers" 
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Block Layers  : It blocks the edition of all the layers, so we'll not be able to edit them until 

unblocking them. In order to block or to unblock a concrete layer, we'll proceed like in the previous 

point, clicking on the point or icon "Lock" located in the current layer under the icon "Block Layers". 

Types of animation (frame and tweened) 

Frame-By-Frame Animation 

Frame-by-frame animation is the way cartoons have been animated since the early days of 

animation. Using this method, the animator draws a figure or 

scene one frame at a time, drawing slight differences between 

each frame. When the frames are then viewed in rapid 

sequence, the differences between them create the illusion of 

change or motion. In Flash, animators impose frame by frame 

animations over still images or other types of animation to avoid redrawing an entire scene for every 

animation frame. 

 

 

1. Flash 8 is a powerful tool created by Macromedia that has overcome the best expectations of 

its creators. 

2. Flash has been made up in order to fix the great lack in the Internet: that is, Dynamism. 

3. Dynamism does not imply only animations but rather interactive animations, which allow users 

to see the web as something attractive, not static 

4. One of the main characteristics of Flash 8 is its simplicity, the straightforwardness in its use 

allows to create animations in an effective and quick way. 

5. The Symbols come from objects that we've created using the tools that Flash 8 provides us. 

6. When we create a symbol, Flash saves it to a library. Every time we use this object in a 

movie, it's converted into an instance. 

7. Graphic symbols are the simplest and most obvious type of symbol. When you create a Flash 

movie, you create objects on the Stage. Some objects may remain still, such as backgrounds 

SUMMARY 
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8. A movie clip is like a movie within a movie that you can manipulate by using interactive 

controls (also called actions, created with ActionScript). 

9. Button symbols create buttons — those little graphics that you click in Web sites to take you to 

other places on the site or the Internet. 

10. The Timeline represents a simple mode of visualization. It consists of two parts: a 

(a)The Frames that are limited by vertical lines and (b)The Numbers of frames that allow us to 

know the assigned number of each frame, its duration and when it will appear in the movie. 

11. A frame represents the content of the movie at one moment of time. 

12. Key Frame is frames with specific contents that are created to insert into the movie inexistent 

content. 

13. A Layer could be defined as one independent movie of only one level. That is to say, 

one layer contains its own Timeline (with endless frames) 

14. Insert Layers   is used for Inserting layers in the present scene. 

15. Frame-by-frame animation is the way cartoons have been animated since the early days of 

animation. 

 

 

 

A. Fill in the blanks 

i. ___________ layer  erase the selected layer. 

ii. If we double click on the ______________properties icon we’ll be able to access a 

panel with the properties of the layer. 

iii. ____________layer blocks the edition of all the layer. 

iv. Using ____________ method , the animator draws a figure or scene one frame at a 

time. 

v. _____________ does not imply only animations but rather interactive animations. 

vi. _____________ is one of the main characteristics of Flash 8. 

vii. A ____________ represents the content of the movie at one moment of time. 

viii. Flash 8 has been made up in order to fix the great lack in the_____________. 

 

EXERCISES 
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B. Find true or false 

 

i. The symbols come from objects that we’ve created using the tools that Flash 8 provides 

us. 

ii. The created symbol is saved into our created file. 

iii. The time line represents complex mode of visualization. 

iv. Graphic symbols are like a movie within a movie that you can manipulate by using 

interactive controls. 

v. A layer could be defined as one independent movie of only one level. 

 

C. Short Answers Questions 

i. What is Flash 8? 

ii. What is key frame? 

iii. Write one difference between Frame and Key frame.? 

iv. Write the use of insert layer.? 

v. What is time line? 

vi. Name the two parts of time line.? 

vii. What is Movie clip? 

viii. What is show/hide layer in flash? 

ix. Write the steps to start Flash 8.? 

x. Write two features of Flash.? 

 

In the lab    

 

 

1. Teachers are suggested to give introductive practical on Flash for familiar with all the tools of 

Flash 8. 

2. Teachers are suggested to show basics practical, which makes animation in Flash 8. 
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Lesson-7 

                         Flash Continued 
 

Motion Tween 
Motion tweens transport a still object across a scene. In Flash,  

an object is animated this way by selecting its start position and  

first animation frame as well as its end position and last animation 

frame within the program. When run, the animation displays the  

object in a different section of the scene for each frame, creating  

the illusion of motion. Motion tweens are also used to move  

background images, which creates the illusion that still images 

in the foreground are in motion. Motion tweens also move two 

or more objects in a scene relative to each other. 

 

 

 

 

 

 

 

 

Shape Tween 

A shape tween changes the shape of an object over a series of frames. In Flash, this is used to 

accomplish a number of effects. Notably, shape tweens are used to animate opening and closing 

mouths or blinking eyes. Melting ice cream is created using a shape tween, as are expanding liquid 

puddles and other similar effects. As with motion tweens, shape tweens are accomplished by placing 

one shape in one animation frame and another shape in a subsequent end frame. When the 

 What is flash and its uses  
 Creating animation 
 About symbols and 

instances 
 Types of symbols(graphic, 

button,movie clip etc.) 
 Converting an object to a 

symbol 
 Introducing time line and its 

use in animation 
 Frames and key frame 
 About layers (inserting a 

new layer, renaming & 
deleting layer) 

 Types of animation (frame 
and tweened) 

 

       You will learn 
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animation is played, Flash generates a shape somewhere between the other two in each intermittent 

frame, creating the image of a smooth transformation between shapes. 

Motion tweening 

 

1. Draw a Shape 

2. Select the shape using Selection tool 

3. Right click on the Shape, click convert into symbol, give a name, select button and click 

ok 

4. click on the 25th or 30th frame, then click insert, click timeline, insert key frame 

5. Rotate the shape or change its direction as you want. 

6. Click on any frame between 1 and 25, right click and select convert to Motion Tween. 

7. play the animation 

Shape tweening 

1. Draw a Shape 

2. click on the 25th or 30th frame, then click insert, click timeline, insert key frame 

3. Draw another shape over the 1st Shape or after erasing the 1st shape. 

4. Click on any frame between 1 and 25 

5. Click window, click properties, and again click properties. 

6. Set the tween option below as - Shape 

7. play the animation 
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1. Motion tweens transport a still object across a scene. 

2. A shape tween changes the shape of an object over a series of frames. In Flash, this is used 

to accomplish a number of effects. 

3. Shape tweens are used to animate opening and closing mouths or blinking eyes. 

4. Shape tweens are accomplished by placing one shape in one animation frame and another 

shape in a subsequent end frame. 

5. In Flash, an object is animated this way by selecting its start position and first animation frame 

as well as its end position and last animation frame within the program. When run, the 

animation displays the object in a different section of the scene for each frame, creating the 

illusion of motion. 

 

 

 

A. Fill in the blanks 

 

i. Animation displays the object in a different section of the scene for each frame by 

creating the _____________of motion. 

ii. Shape tweens are used to animate ________ and _________ mouths or blinking 

eyes. 

iii. Shape tween changes the ___________ of an object. 

 

 

 

SUMMARY 

EXERCISES 
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B. Short Answer Questions 

 

i. What is Motion tweens? 

ii. Why shape tween is require in Flash animation? 

iii. Write the steps for shape tweening. 

iv. Write the steps for motion tweening 

 

 

 

In the lab    

 

1. Create an animation by using Shape tweeinig by creating Smiley. 

2. Create an animation by using Motion tweeinig by creating Smiley. 
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Lesson-8 

                         E-Commerce 
 

EDI(Electronic Data Interchange) 

Electronic data interchange (EDI) is an electronic communication  

method that provides standards for exchanging data via any  

electronic means. Two different companies or organizations,  

even in two different countries, can electronically exchange  

documents (such as purchase orders, invoices, shipping notices,  

and many others). EDI implies a sequence of messages between  

two parties, either of whom may serve as originator or recipient.  

The formatted data is transmitted via telecommunications or  

physically transported on electronic storage media using wires 

 

What is E-Commerce and E-Greetings? 

E-CommerceItreferstoanyform oftransaction(exchange)thatusesanelectronicmediumto 

facilitatethetransaction. 

Social impacts of E- Business: 

 Reductions in transactions and other costs. 

 Increase in the internet users. 

 Un-shortened supply chain. 

 EDI(Electronic Data 
Interchange) 

 What is E-Commerce and E-
Greetings ? 

 Influence on user 
 What factor one should keep 

in mind while doing e-
commerce, Websites 
Example 

 

       You will learn 
 

https://en.wikipedia.org/wiki/Data
https://en.wikipedia.org/wiki/Purchase_orders
https://en.wikipedia.org/wiki/Invoices


 

  72 | P a g e  

 

 
 Improved customer service. 

 Increased productivity/efficiency. 

 Access to international markets. 

 

SomeE-Businesswebsitesare: 

NameofWebsite Purpose 
www.irctc.co.in It providesonlinerailwayticketreservationinIndia. 

www.licindia.com Insurancecompanyof India. 

www.ebay.in India’smostpopularonlineshoppingmallprovidingfre

eonlineauctions. 
www.amazon.com OnlinestoreforBooks,CD’s,DVD’s,MP3’setc. 

www.yatra.com Onlineflightticketbookingservice. 

 

An E-card is similar to a postcard or greeting card, with the primary difference being that it is created 

using digital media instead of paper or other traditional materials. E-cards are made available by 

publishers usually on various Internet sites, where they can be sent to a recipient, usually via e-mail. 

It also considered more environmentally friendly compared to traditional paper cards. E-card 

businesses are considered environmentally friendly because their carbon footprint is generally much 

lower compared to paper card companies and because paper is not used in the end product. 

E-cards can be easily sent to many people at once or extensively personalized by the sender 

Typically, an E-card sender chooses from an on-line catalog of E-cards made available on a 

publisher's web site. After selecting a card, the sender can personalize it to various degrees by 

adding a message, photo, or video. Finally, the sender specifies the recipient's e-mail address and 

the web site delivers an e-mail message to the recipient on behalf of the sender. 

http://www.irctc.co.in/
http://www.licindia.com/
http://www.ebay.in/
http://www.amazon.com/
http://www.yatra.com/
https://en.wikipedia.org/wiki/Postcard
https://en.wikipedia.org/wiki/Greeting_card
https://en.wikipedia.org/wiki/Digital_media
https://en.wikipedia.org/wiki/Internet
https://en.wikipedia.org/wiki/E-mail
https://en.wikipedia.org/wiki/Environmentally_friendly
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Types of E-card: 

 Flash animation 

 This type of E-card is based on two-dimensional vector animation controlled with 

a scripting language. Flash animated greeting cards can include interactivity, for 

example, asking the viewer to choose a picture to animate;  

 Video E-cards 

 "Video E-cards" use a combination of personalized text and video to convey the 

message to the recipient.  

 Mobile E-cards 

 With the advance in mobile technologies, Multimedia Messaging Service (MMS) 

which is basically picture SMS, became more and more popular.  

 Web based multi-media E-cards 

 The web-based card creation has been evolving becoming more creative. The 

user can create greeting cards online choosing backgrounds, drag and drop 

images, animations, smiles and write text that look like handwriting.  

 E-cards games 

 Some E-cards include interactive games.  

 

Influence on user 

ADVANTAGES OF ECOMMERCE 

 Faster buying/selling procedure, as well as easy to find products. 

 Buying/selling 24/7. 

 More reach to customers, there is no theoretical geographic limitations. 

 Low operational costs and better quality of services. 

 No need of physical company set-ups. 

 Easy to start and manage a business. 

 Customers can easily select products from different providers without moving around physically. 
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DISADVANTAGES OF ECOMMERCE 

 Any one, good or bad, can easily start a business. And there are many bad sites which eat up 

customers’ money. 

 There is no guarantee of product quality. 

 Mechanical failures can cause unpredictable effects on the total processes. 

 As there is minimum chance of direct customer to company interactions, customer loyalty is 

always on a check. 

 There are many hackers who look for opportunities, and thus an ecommerce site, service, 

payment gateways, all are always prone to attack. 

 

What factor one should keep in mind while doing e-

commerce? 

1 Privacy  

It is easy to collect a lot of personal information from a 

consumer using an e-commerce website,  

2 Security  

Online transactions are inherently more insecure than those conducted in person because 

there's no way to guarantee that the person making the payment is the actual owner of the 

credit card used.  

 

3 Price Wars  

Merchants used to selling at their shop may often find selling online an extremely competitive 

marketplace. or products are purchased from illegitimate retailers because they had the best 

price. 
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4 Returns And Complaints  

Selling online means usually a higher return rate on products than when the purchase was 

conducted in person. 

 

1. Electronic data interchange (EDI) is an electronic communication method that provides 

standards for exchanging data via any electronic means. 

2. EDI implies a sequence of messages between two parties, either of whom may serve as 

originator or recipient. 

3. E-CommerceItreferstoanyform 

oftransaction(exchange)thatusesanelectronicmediumto facilitatethetransaction. 

4. An E-card is similar to a postcard or greeting card, with the primary difference being that it is 

created using digital media instead of paper or other traditional materials. 

5. E-card businesses are considered environmentally friendly because their carbon footprint is 

generally much lower compared to paper card companies and because paper is not used in 

the end product. 

6. Flash animation :This type of E-card is based on two-dimensional vector animation controlled 

with a scripting language. 

7. Video E-cards :use a combination of personalized text and video to convey the message to the 

recipient. 

8. Mobile E-cards :With the advance in mobile technologies, Multimedia Messaging Service 

(MMS) which is basically picture SMS, became more and more popular.  

9. Web based multi-media E-cards :The web-based card creation has been evolving becoming 

more creative. The user can create greeting cards online choosing backgrounds, drag and 

drop images, animations, smiles and write text that look like handwriting.  

10. E-cards games :Some E-cards include interactive games.  

 

SUMMARY 

EXERCISES 

https://en.wikipedia.org/wiki/Data
https://en.wikipedia.org/wiki/Postcard
https://en.wikipedia.org/wiki/Greeting_card
https://en.wikipedia.org/wiki/Digital_media
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A. Fill in the blanks 

 

i. EDI implies a sequence of _______________between two parties. 

ii. _____________refers to any form of transaction that uses an electronic medium. 

iii. _____________ based on two dimensional vector animation. 

iv. Video-E-Cards use a combination personalized __________and ___________ to 

convey the message. 

v. ___________is easy to collect personal information from a consumer using E-

Commerce website. 

B. Find true or false 

i. EDI is an electronic communication method. 

ii. An E-Card is similar to birthday card. 

iii. MMS is Multimedia Message Server. 

iv. Some E-Card includes interactive entertainment movie. 

v. E-Card businesses are considered environmentally friendly. 

C.  Short Answer Questions 

i. What is EDI? 

ii. What do you mean by E-Commerce? 

iii. Name some E-Commerce website.? 

iv. What is E-Card? Name some E-Cards. 

v. Write two advantage of E-Card. 

vi. Write two disadvantage of E-Card. 

vii. Write short notes on: 

a) Price Wars. 

b) Return and Complaints. 

c) Security. 

 

 



 

  77 | P a g e  

 

 
 

In the lab    

 

1. Teachers are requested to show all the E-Commerce websites which discussed in the lesson. 

2. Teachers are requested to show the disadvantage of E-Commerce with advantage by choosing 

any E-Commerce website. 
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Lesson-9 

                             Chatting 

 

Chatting 

Definition 

May refer to any kind of communication over the Internet that offers  

a real-time transmission of text messages from sender to receiver.  

Chat messages are generally short in order to enable other  

participants to respond quickly. Online chat may address point- 

to-point communications as well as multicast communications  

from one sender to many receivers and voice and video chat,  

or may be a feature of a web conferencing service.Online chat can 

be direct text-based or video-based (webcams), one-on-one chat or 

one-to-many group chattools such as instant messengers, Internet 

Relay Chat (IRC), talkers  

and possibly MUDs.  

Example 

The following are common chat programs and protocols: 

 AOL Instant Messenger (AIM) 

 Google Talk 

 Internet Relay Chat (IRC) 

 

 

 Definition 
 Example 

       You will learn 
 

https://en.wikipedia.org/wiki/Communication
https://en.wikipedia.org/wiki/Internet
https://en.wikipedia.org/wiki/Real-time_text
https://en.wikipedia.org/wiki/Text-based
https://en.wikipedia.org/wiki/Multicast
https://en.wikipedia.org/wiki/Videotelephony
https://en.wikipedia.org/wiki/Web_conferencing
https://en.wikipedia.org/wiki/Webcam
https://en.wikipedia.org/wiki/Chat_room
https://en.wikipedia.org/wiki/Instant_messenger
https://en.wikipedia.org/wiki/Internet_Relay_Chat
https://en.wikipedia.org/wiki/Internet_Relay_Chat
https://en.wikipedia.org/wiki/Internet_Relay_Chat
https://en.wikipedia.org/wiki/Talker
https://en.wikipedia.org/wiki/MUD
https://en.wikipedia.org/wiki/AOL_Instant_Messenger
https://en.wikipedia.org/wiki/Google_Talk
https://en.wikipedia.org/wiki/Internet_Relay_Chat
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 Skype 

 WhatsApp 

 Windows Live Messenger 

 Yahoo! Messenger 

 
 

1. Chatting may refer to any kind of communication over the Internet that offers a real-

time transmission of text messages from sender to receiver. 

2. Online chat may address point-to-point communications as well as multicast communications 

from one sender to many receivers and voice and video chat, or may be a feature of a web 

conferencing service 

3. Online chat can be direct text-based or video-based (webcams), one-on-one chat or one-to-

many group chattools such as instant messengers, Internet Relay Chat (IRC), talkers  

4. Google Talk, Internet Relay Chat (IRC)are the example of Online chat. 

 

 
 

A. Fill in the blanks 

 

i. Skype is an example of______________. 

ii. Online chat can be direct ____________or ______________. 

iii. IRC means______________________. 

 

 

B. Short Answer Questions 

 

i. What do you mean by Chatting? 

ii. Write one difference between text based chat and video based chat. 

iii. Write for Chat application. 

 

SUMMARY 

EXERCISES 

https://en.wikipedia.org/wiki/Communication
https://en.wikipedia.org/wiki/Internet
https://en.wikipedia.org/wiki/Real-time_text
https://en.wikipedia.org/wiki/Real-time_text
https://en.wikipedia.org/wiki/Text-based
https://en.wikipedia.org/wiki/Multicast
https://en.wikipedia.org/wiki/Videotelephony
https://en.wikipedia.org/wiki/Web_conferencing
https://en.wikipedia.org/wiki/Web_conferencing
https://en.wikipedia.org/wiki/Web_conferencing
https://en.wikipedia.org/wiki/Webcam
https://en.wikipedia.org/wiki/Chat_room
https://en.wikipedia.org/wiki/Instant_messenger
https://en.wikipedia.org/wiki/Internet_Relay_Chat
https://en.wikipedia.org/wiki/Talker
https://en.wikipedia.org/wiki/Google_Talk
https://en.wikipedia.org/wiki/Internet_Relay_Chat
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In the lab    

 
 

1. Teachers are requated to show few  Online chat Example.  
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Lesson-10 

                     Downloading/Uploading 

 
Downloading/Uploading Speed  
 

 

 

 

 

 

DownloadWhen you connect to the internet, the download speed is the pace at which data 

(websites, programmers, music etc.) is transferred from another computer to your own. Currently, 

when it comes to home broadband, download speeds range from 8 Mbps to 100 Mbps 

Upload speed on the other hand is the speed at which data (such as your pictures and videos) is 

uploaded to the internet – perhaps to put onto a social networking site such as Facebook, or file-

sharing site such as Flickr; Essentially, the upload is going in the opposite direction to the download – 

from your computer to someone else’s. 

Broadband upload speeds are generally much slower than download speeds. The reason for this is 

that people generally do far more downloading than uploading, and as such downloading is given 

priority by internet service providers (ISPs). 

 

 

 

 
 Downloading/Uploadi

ng Speed  

 Difference  

 Example 

 Concept of Bandwidth 

and protocol 

       You will learn 
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Difference  

Speed 

The time that it takes to upload or download a file depends on several factors. The main factor is the 

digital size of the file, which is measured in bytes. The larger the file, the longer it takes to transfer the 

information in it. 

The quality of the connection from the Internet or central server to the smaller computer or device 

also makes a difference in the transfer speed. A computer that has high-speed Internet connection 

will be able to download or upload a file much more quickly than a computer that has a low-speed 

connection would. In addition, the speed of the server on which the file is stored can affect upload 

times or download times. 

Background Operations 

Uploading and downloading occur frequently, often without the user being aware that he or she is 

doing it. For example, incoming email is downloaded from a server, and outgoing emails are 

uploaded to be sent out. 

 

Example 

Downloading 

1. Songs, Videos, files from the net 

2. Text or Images that are displayed on your browser 

Uploading 

1. Sending emails 

2. Posting Comments, status or pics on various social networking sites 

 

 

* To be shown in practical by teacher 

http://www.wisegeek.com/what-is-email.htm
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Concept of Bandwidth and protocol 

Bandwidth is the bit-rate of available or consumed information capacity expressed typically in metric 

multiples of bits per second. Variously, bandwidth may be characterized as network bandwidth, data 

bandwidth, or digital bandwidth.  

Bandwidth is a term used in the field of signal processing, wireless communications, modem data 

transmission, digital communications, and electronics, in which bandwidth is used to refer to 

analog signal bandwidth measured in hertz, meaning the frequency range between lowest and 

highest attainable frequency while meeting a well-defined impairment level in signal power. 

Protocols are rules exist at several levels in a telecommunication connection. Example, there are 

protocols for the data interchange at the hardware device level and protocols for data interchange at 

the application program level. In Open Systems Interconnection (OSI), there are one or more 

protocols at each layer in the telecommunication exchange that both ends of the exchange must 

recognize and observe. 

The TCP/IP  Internet protocols, a common example, consist of: 

 Transmission Control Protocol (TCP), which uses a set of rules to exchange messages with 

other Internet points at the information packet level 

 Internet Protocol (IP), which uses a set of rules to send and receive messages at the Internet 

address level 

 Other Protocol are Hypertext Transfer Protocol (HTTP) and File Transfer Protocol (FTP),  

 

 

 

 

 

https://en.wikipedia.org/wiki/Signal_bandwidth
https://en.wikipedia.org/wiki/Hertz
http://searchnetworking.techtarget.com/definition/OSI
http://searchnetworking.techtarget.com/definition/TCP-IP
http://searchunifiedcommunications.techtarget.com/definition/Internet-Protocol
http://searchenterprisewan.techtarget.com/definition/File-Transfer-Protocol
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1. Downloading refers to copying a file from network file server to the computer on the network. 

2. Uploading refers to copying a file from computer to the network file server. 

3. The time that it takes to upload or download a file depends on several factors. The main factor 

is the digital size of the file, which is measured in bytes. 

4. Uploading and downloading occur frequently, often without the user being aware that he or she 

is doing it. For example, incoming email is downloaded from a server. 

5. Bandwidth is the bit-rate of available or consumed information capacity expressed typically in 

metric multiples of bits per second. 

6. Protocols are the common set of rules which is used by the computer on the network to 

communicate different types of devices. 

7. In Open Systems Interconnection (OSI), there are one or more protocols at each layer in the 

telecommunication exchange that both ends of the exchange must recognize and observe. 

8. Transmission Control Protocol (TCP), which uses a set of rules to exchange messages with 

other Internet points at the information packet level 

9. Internet Protocol (IP), which uses a set of rules to send and receive messages at the Internet 

address level 

10. Other Protocol are Hypertext Transfer Protocol (HTTP) and File Transfer Protocol (FTP). 

 

SUMMARY 

http://searchnetworking.techtarget.com/definition/OSI
http://searchunifiedcommunications.techtarget.com/definition/Internet-Protocol
http://searchenterprisewan.techtarget.com/definition/File-Transfer-Protocol
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A.  Fill in the blanks 
 

i. ______________reafers to copying a file from network file server to the computer on 

the network. 

ii. ______________refers to copying a file from computer system to the network file 

server. 

iii. ______________ is bit rate of available or consumed information capacity. 

iv. ______________ is common set of rules. 

 
 

B. Short Answer Questions 

 

i. What is Downloading? 

ii. What is Uploading? 

iii. Write one difference between Downloading and Uploading. 

iv. Give few example of Downloading and Uploading 

v. What is TCP/IP Protocol? 

vi. Write full forms of: 

a) FTP 

b) TCP 

c) IP 

d) HTTP 

e) OSI 

 

 

 

EXERCISES 
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In the lab    

 

1. Download some images and upload it using E-mail. 
 
Teachers are requested to show them in Practical Class. 
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Lesson-11 

                 Audio and Video Conferencing 

Audio and Video Conferencing 

What is it 

An audio conference, or teleconference, is simply when a meeting  

between several parties is held over the telephone instead of in person.  

The party instigating the audio-conference is known as the calling  

party and those joining the call are known as the participants. 

Videoconferencing is the conduct of a videoconference (also known as a video conference or 

video teleconference) by a set of telecommunication technologies which allow two or more locations 

to communicate by simultaneous two-way video and audio 

transmissions. 

Use of It 

1. Video and audio, or just audio connection between two 

computers communicating via the Internet. 

Examples of free audio conferencing software: Gizmo, Skype both enable users to speak to 

other Gizmo/Skype users free of charge Examples of free video conferencing, 

software: iVisit (cross platform), iChat (Mac only), NetMeeting (Windows only). 

 

2. Breeze can also be used for video conferencing  

 

3. Transmitted to & received from any computer in any location that has Internet. User must 

have microphone, can have camera. Ideally every user has microphone (camera not 

essential) for synchronous communication. 

 
 What is it 

 Use of It 

 Factors affecting Video 

Quality 

 Usefulness of Video 

Conferencing  

 

       You will learn 
 

http://www.gizmoproject.com/
http://www.skype.com/
http://www.ivisit.com/
http://www.apple.com/macosx/features/ichat/
http://www.microsoft.com/windows/NetMeeting/default.ASP
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4. Technology requirements for video/audio conferencing: 

 Computer with access (ideally broadband) to the Internet. 

 Browser. 

 Speakers to hear audio. 

 Microphone (to contribute audio). 

 Web camera to contribute video. 

Factors affecting Video Quality 

The speed of the network connection is one of the biggest contributors to quality. If the network 

connection is slow or unstable (such as over the open internet) the video session can be unusable. 

Newer equipment (manufactured after 1999) can produce excellent motion pictures from even slow 

speed connections and therefore can significantly contribute to better quality images. 

 

Some seemingly minor factors can seriously affect quality. Microphone placement and function 

significantly affect video conference quality because the audio clarity of a meeting is critical to the 

perception of quality. Further, the amount of movement the meeting participants create, if great, can 

cause codecs (the video conferencing engine) to create blurred images as they process 

communications signals. Finally, the type-size of fonts used in computer presentations if too small 

can be illegible to both near and far-end meeting participants. Tec phonic can offer assistance with all 

of these quality factors and more. Contact us for more information. 

Usefulness of Video Conferencing 

Video conferencing can be used in a host of different environments, which is one of the reasons the 

technology is so popular. General uses for video conferencing include business meetings, 

educational training or instruction and collaboration among health officials or other representatives. 

Thus far video conferencing has been used in the following fields: 
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 Business: Videoconferencing provides businesses with the ability to meet and to work with 

others over a distance. 

 Distance Learning: Videoconferencing is an exciting technology for education. Teachers 

and students are able to see each other, share documents and discuss topics together in a 

situation similar to a traditional classroom setting 

 Telecommuting / Home Offices: Working out of home has never been easier or more 

practical. Videoconferencing makes it possible to stay connected with people in a very real 

way.  

 Legal Environment: The use of videoconferencing technology is becoming more prevalent 

in today’s courtrooms. Videoconferencing systems are used to enable testifying witnesses 

to ―appear‖ in court without having to travel to the courtroom.  

 Telemedicine: There are times when a person needs medical advice but is unable to visit 

their personal physician or even more likely, a specialist. In such situations using 

videoconferencing can make all the difference. 

 

1. An audio conference, or teleconference, is simply when a meeting between several parties is 

held over the telephone instead of in person.  

2. The party instigating the audio-conference is known as the calling party and those joining the 

call are known as the participants. 

3. Videoconferencing is the conduct of a videoconference (also known as a video conference or 

video teleconference) by a set of telecommunication technologies, which allow two or more 

locations to communicate by simultaneous two-way video and audio transmissions. 

4. If the network connection is slow or unstable (such as over the open internet) the video session 

can be unusable 

5. Video conferencing can be used in a host of different environments, which is one of the reasons 

the technology is so popular 

 

SUMMARY 

http://picturephone.com/learn/uses.html#business
http://picturephone.com/learn/uses.html#distance
http://picturephone.com/learn/uses.html#telecommuting
http://picturephone.com/learn/uses.html#legal
http://picturephone.com/learn/uses.html#telemedicine
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A. Fill in the blanks 

 

i. ______________ conference is simply when a meeting between several parties is held 

over the telephone. 

ii. The party instigating the audio conference is knownas_______________party. 

iii. Video conference is the conduct of a video conference by a set of_________________. 

iv. Breeze can also be used for ____________. 

v. The ____________of the network connection is one of the biggest contributors to 

quality. 

 

B. Find true or false 

 

i. Audio conference is takes place with Miscrophone. 

ii. The party instigating the audio-conference is known as the participants. 

iii. Video conferencing can be used in a host of different environments, which is one of the 

reasons the technology is so popular 

iv. Audio/Video Conferencing does not require any internet connection. 

 

C.  Short Answer Questions 

i. What is audio conferencing? 

ii. What is video conferencing? 

iii. Write the technology requirements for video/audio conferencing. 

iv. Give some example where Audio/Video conference takes place. 

v. Who is calling party and participants in context with audio conferencing? 

 

 

EXERCISES 


